Search found 2851 matches

by Dbug
Thu Jan 18, 2007 9:41 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

Last, but not least, I have turn ROM off during all gameplay and adjusted irq routines to work (in fact I replace normal irq routine -Twilighte's- with disk irq routine when saving/loading and then install it again -- I suppose this is not a problem). This means no more sounds. No more tic-toc soun...
by Dbug
Wed Jan 17, 2007 8:11 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

It is mostly a kludge but it works rather well, imho. And it was something Dbug and Twilighte claim to have in the game, so I expend some time trying to do it... The kind of 'kludge' that makes the difference between an enjoyable game, and a frustrating experience :) The idea will be detecting when...
by Dbug
Tue Jan 16, 2007 9:02 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

Chema wrote:So you did not download the map from my post previous to the one with the demo... :twisted:
Have to admit that I did not saw the message.
I downloaded the maps, dude, they are great !
Actually they are exactly the way I wanted them to be :D
by Dbug
Tue Jan 16, 2007 7:43 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

Nobody noticed that the overall speed has been increased? That means it was not quite noticeable :oops: ...runs very smoothly too. Controls react very well... Was thinking that this sentence was clear enough, obviously not :) The speed is way better than earlier ! Now for the map, it does not neces...
by Dbug
Mon Jan 15, 2007 11:46 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

Feedback on the demo :) Well, first I have to say that it looks graphicaly very nice, and runs very smoothly too. Controls react very well, and the presence of loading and saving code is a great plus for being able to test correctly ! Also big big plus is the "collisiong sliding" code. It works very...
by Dbug
Sat Jan 13, 2007 2:53 pm
Forum: General Discussion
Topic: Oric Forth
Replies: 4
Views: 5276

Looks like the Oric Forth exists in Sedoric compatible version: http://oric.free.fr/F83/f83m.html This page is in French, but obviously if you try to contact Thierry Bestel you could have a lot of information about this, and most probably get the very last versions that seem to be debugged and impro...
by Dbug
Fri Jan 12, 2007 9:52 am
Forum: General Discussion
Topic: Oric Forth
Replies: 4
Views: 5276

No idea about that. I never used Forth.

Do you know if there are portable free cross Forth compilers ? Could be something I could add in the OSDK. Would give people the choice between BASIC, C, Assembler and Forth :)
by Dbug
Thu Jan 11, 2007 9:10 pm
Forum: Technical questions
Topic: no colour on my atmos
Replies: 18
Views: 17677

Re: WILL THIS MONITOR WORK

SORRY LAST QUESTION ON THIS SUBJECT ,HI GUYS IVE GOT THE CHANCE OF A PHILIPS MONITOR PREVIOUSLY USED WITH AN AMIGA A1200 WILL THIS BE COMPATABLE IF I MAKE A LEAD? Most probably :) Do you have the reference model/type of the monitor ? If it's a real rgb monitor, you only need the 4 wires, no transis...
by Dbug
Mon Jan 08, 2007 11:15 am
Forum: Technical questions
Topic: no colour on my atmos
Replies: 18
Views: 17677

Think it's chanel 36.
by Dbug
Sat Jan 06, 2007 3:44 pm
Forum: C programming
Topic: HowTo: C Programming on the Oric
Replies: 6
Views: 11195

HowTo: C Programming on the Oric

While doing some googling, I found out this: "This series of articles is a C language tutorial, focused on using C efficiently on Oric computers" So if you wish to learn C, you can learn with that, it's quite nicely written, and I feel a bit ashamed to never have found it earlier ! http://www.bedroo...
by Dbug
Fri Jan 05, 2007 9:23 pm
Forum: Technical questions
Topic: no colour on my atmos
Replies: 18
Views: 17677

Yep, there is a difference. The Antena format is difference in France and Uk. Actually the first models of Atmos sold in France (build in UK) were not usable with the antenna cable, all you got was kind of wobbling, fuzzy, video inverted black and white picture. There was some hacks involving transi...
by Dbug
Fri Jan 05, 2007 9:10 pm
Forum: Technical questions
Topic: no colour on my atmos
Replies: 18
Views: 17677

Hi.

Are you using the antenna socket, or the RGB connector ?
by Dbug
Thu Jan 04, 2007 8:24 pm
Forum: Games
Topic: Space99 - Development Forum
Replies: 389
Views: 376550

What about trying:

Code: Select all

.dsb $a000-*
No idea if it work, but worth trying ?
by Dbug
Sun Dec 31, 2006 8:04 pm
Forum: Technical questions
Topic: Faulty Ram / Faulty Oric
Replies: 11
Views: 12616

Well, the ROM is never copied to RAM for what I know, it is just "overlaying" the RAM.

Now, what would be the behaviour with missing RAM chips, I have absolutely no idea.

I guess you will have to wait for everybody to be back from end of year parties before you get any interesting answers !
by Dbug
Sun Dec 31, 2006 7:28 pm
Forum: Cross development tools
Topic: XA and page boundary allignment
Replies: 1
Views: 5313

Re: XA and page boundary allignment

I know that the line... .dsb 256-(*&255) can be used to allign to a page boundary, but does anyone know how i can allign to half a page boundary or an exact low address? Essentially, i am creating a backup of the screen ($bb80) and need to restore parts of it, passing the screen address to the rout...