Search found 37 matches

by SpaceFlightOrange
Sun Dec 08, 2019 11:47 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

signal-2019-12-08-085024.jpeg Thank You, and, Goodnight :D RAM arrived from Bulgaria (Finally) NOS Fujitsu MB8264-15. It's been sitting there for a few days to be honest, but I was trying to get the Spectrum refurb done, but the keyboard was giving me some grief (its in a Lo>>Profile Keyboard case,...
by SpaceFlightOrange
Thu Dec 05, 2019 11:00 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Imo, there seems to be little or no quality-control in operation from most of these cheap Chinese component manufacturers. So has Phil used to say on HSB, "let's be careful out there." I think you’re right. Best guess the ram I have is because they all appear to work they can’t be managing the adve...
by SpaceFlightOrange
Tue Dec 03, 2019 1:51 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Thanks mike. I’ll get on that while I’m waiting.

I did check the dram lines when I socketed them but I didn’t check from the multiplexer to the ULA. But I’ll go back over everything.
by SpaceFlightOrange
Mon Dec 02, 2019 12:30 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

That's when this happens you are glad you spent the time installing sockets instead of soldering directly the new chips :D 100% agree. That goes double when you venture into removing the PSG, VIA and CPU! +1 here. I was fully expecting to go down the road of removing the CPU, VIA and PSG, but hopef...
by SpaceFlightOrange
Mon Dec 02, 2019 12:25 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Sorry for the delayed reply, I’ve been on shift this morning and repairing a Spectrum this afternoon and having considerably more success :lol: With the DRAMArduino (I'm not familiar with it), make sure you're testing the chip at the right "speed", because if the DRAM chip is slower than needed, it ...
by SpaceFlightOrange
Sun Dec 01, 2019 2:09 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Sounds right to me, so does that mean the CPU, VIA, and AY are ok? This is also hooked up to my Bench PSU and I can see that the Atmos is drawing 700 milliamps. Yes, this is the correct sound and it means 99.99% CPU,VIA and AY are OK (diag EPROM too, obviously :)). So the only suspect is the RAM, u...
by SpaceFlightOrange
Sat Nov 30, 2019 9:21 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Ok, So.

A0 & A1 are like this (Pulsing):
A1.jpg
A1.jpg (133.13 KiB) Viewed 259 times
A2 is like this:
A2.jpg
A2.jpg (118.79 KiB) Viewed 259 times
and A3 is like this:
A3.jpg
A3.jpg (138.21 KiB) Viewed 259 times
A4-A7 are low and A8=A15 are all high.

So it looks like it completed the first test and failed on the full test.
by SpaceFlightOrange
Sat Nov 30, 2019 8:58 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Yes, this is the correct sound and it means 99.99% CPU,VIA and AY are OK (diag EPROM too, obviously :)). So the only suspect is the RAM, until it arrives you can try DRAMARDUINO to test your chips. And I think 700 mA is bit higher ... Wow! that's so cool. I don't have an Uno, but I do have a Nano, ...
by SpaceFlightOrange
Sat Nov 30, 2019 7:26 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

What does your scope/probe show is happening on the address bus after boot? If you have DRAM read-write issues, this will definitely die at "ERR_RAM_QUICK" (a JMP loop to itself, placed so that the addresses will cycle as described above). Thanks for the really quick reply. Sorry for not giving any...
by SpaceFlightOrange
Sat Nov 30, 2019 6:16 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

I've burned both Mike's Diagnostic ROM and ISS's ROM. I got nothing when running Mikes ROM, but I got this with ISS's ROM: https://youtu.be/zQi-OPdDG4s Sounds right to me, so does that mean the CPU, VIA, and AY are ok? *** EDIT *** This is also hooked up to my Bench PSU and I can see that the Atmos ...
by SpaceFlightOrange
Wed Nov 27, 2019 2:45 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Here my diagnostic ROM running on Oric without RAM. The "busy tone" is bit tiny because no LM386 amplifier - the signal is directly from AY's output pins (not very good idea! :mrgreen: ). https://youtu.be/L28cXINhAck Wow, thats a seriously stripped down board! I'm going to source a couple of ROMs a...
by SpaceFlightOrange
Wed Nov 27, 2019 2:45 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

TL;DR -- if you ripped out the CPU, VIA, PSG and ROM you'd still get a pattern :) You've changed the important multiplexer/inverter near the RAM, and the RAM itself. There's not much left to swap, other than the CPU, VIA and PSG, which are all soldered in :( I guess then I'll wait for the next batc...
by SpaceFlightOrange
Wed Nov 27, 2019 2:11 am
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

I have a 16KB EPROM burned with the test ROM if you want to borrow it. Haven’t read all of the thread so just to say have you changed the 12Mhz Crystal? Haven't changed the crystal, but further up the thread is a capture from my scope showing the clock signal. that said I've not checked this since ...
by SpaceFlightOrange
Mon Nov 25, 2019 8:31 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

So you think it’s still a ram issue? Does the pattern suggest the CPU might be functioning? The ram I’ve gotten was admittedly cheap stuff from China, but I’ve bought some more from hopefully a better source, a little more expensive so fingers crossed. None of the chips are getting hot. And the sign...
by SpaceFlightOrange
Sat Nov 23, 2019 4:38 pm
Forum: Technical questions
Topic: New Member and New Oric Atmos Owner
Replies: 68
Views: 1782

Re: New Member and New Oric Atmos Owner

Hi. I've removed the 2 multiplexers and the inverter and socketed them. 3 new chips in. IMG_0238.JPEG I now get this: IMG_0234.jpg Swapped the ROM and its pretty much the same but with a bit of colour: IMG_0241.JPEG There's definitely a pattern there. I feel like im getting close. I haven't tried th...